Bug #7

Mockator does not work out of the box.

Added by Christoph Thurnheer about 5 years ago. Updated almost 5 years ago.

Status:ResolvedStart date:09/07/2012
Priority:ImmediateDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

I can not activate mockator. It does not work neither with right click on the project->mockator->add mockator support, nor with a new cute projekt clicking on add mockator support.

problems_encountered_while_setting_project_description.log (620 KB) Christoph Thurnheer, 09/07/2012 01:40 PM

Problems_occurred_when_invoking_code.log (620 KB) Christoph Thurnheer, 09/07/2012 01:40 PM

Resource_mockator_headers_not_exist.log (28.2 KB) Christoph Thurnheer, 09/10/2012 11:16 AM

Prob_occurred_invoking_code.log (28.2 KB) Christoph Thurnheer, 09/10/2012 11:16 AM

Prob_encountered_setting_project_description.log (28.2 KB) Christoph Thurnheer, 09/10/2012 11:16 AM

Internal_error_1.log (28.2 KB) Christoph Thurnheer, 09/10/2012 11:16 AM

Internal_error_2.log (28.2 KB) Christoph Thurnheer, 09/10/2012 11:16 AM

mockator.zip (1.57 MB) Christoph Thurnheer, 09/10/2012 03:13 PM

Prob_encountered_setting_project_description.log (36.1 KB) Christoph Thurnheer, 09/11/2012 09:35 AM

Prob_occurred_invoking_code.log (36.1 KB) Christoph Thurnheer, 09/11/2012 09:35 AM

Resource_mockator_headers_not_exist.log (36.1 KB) Christoph Thurnheer, 09/11/2012 09:35 AM

History

#1 Updated by Michael Rüegg about 5 years ago

Hi,

From your error log I see several issues:

1. It seems that you are using Eclipse Juno but with an old CUTE plug-in that does not support Juno. Please update your CUTE plug-in.
2. Did you use the Mockator plug-in from the Juno repository (http://www.mockator.com/update/juno)?
3. You seem to have a too small perm size. Please increase it in your eclipse.ini file (-XX:MaxPermSize=XXXM)

Hope that helps.

Thanks,
Michael

#2 Updated by Christoph Thurnheer about 5 years ago

I reinstalled juno.
I reinstalled the cute version.
I reinstalled mockator (the .../update/juno version).
And I have changed the eclipse.ini file but unfortunatly the mockator still does not work.

#3 Updated by Michael Rüegg about 5 years ago

Thanks, the perm gen errors are gone now.

What toolchain are you using?

Is the project you attempt to add Mockator an open source project? It would be great if I could reproduce this behaviour on my machine. Thanks

#4 Updated by Christoph Thurnheer about 5 years ago

Well I tried using MinGW GCC but if there is something better I would change to that.
The project I try to add Mockator is infact a bare metal embedded project.
But so far I just wanted to try out mockator, so I tried with a "Hello World" project and the sample cute project.

#5 Updated by Christoph Thurnheer about 5 years ago

I tried it on these projects.

#6 Updated by Michael Rüegg about 5 years ago

Ah, that explains the problem. We currently only support Cygwin under Windows. Could you please try with that for the moment? I will try to support MinGW with the next release of Mockator. Thanks

#7 Updated by Michael Rüegg about 5 years ago

I did a new build including MinGW support. Please update your Mockator plug-in and retry. Thanks.

#8 Updated by Christoph Thurnheer about 5 years ago

I now changed to Cygwin but it still does not work. It seems when Mockator creates the mockator folder, the mockator.h file does not get copied,

#9 Updated by Michael Rüegg about 5 years ago

Hi, I'm very sorry for answering that late. I had to organize a virtual image for Windows to reproduce this problem because it only happens on this platform. I'll try to fix the bug asap and will come back to you as soon as I have fixed it. Thanks

#10 Updated by Michael Rüegg almost 5 years ago

  • Status changed from New to Resolved

The bug should be fixed. Please try again on Windows. Thanks.

Also available in: Atom PDF